View unanswered posts | View active topics It is currently November 21st, 2017, 3:44 pm



Reply to topic  [ 13 posts ]  Go to page 1, 2  Next
 Incompatibility with .Net Framework 4.0 
Author Message

Joined: May 10th, 2010, 6:37 pm
Posts: 6
Post Incompatibility with .Net Framework 4.0
Hello,

I just installed .NET 4.0 on Windows 7 64-bit and here's the problem...
As long as SupTitle.dll and SupCore.dll are in avisynth's plugin folder, avisynth crashed

Code:
Unhandled Exception: System.IO.FileLoadException: Could not load file or assembly 'SupTitle, Version=1.0.3776.32233, Culture=neutral, PublicKeyToken=null' or one of its dependencies. Method does not exist. (Exception from HRESULT: 0x80131513)

File name: 'SupTitle, Version=1.0.3776.32233, Culture=neutral, PublicKeyToken=null' ---> System.MissingMethodException: Missing entrypoint in MSCOREE: 'GetTokenForVTableEntry'.


I tried both 1.0.9 and 1.0.10beta but SupTile doesn't work with .NET 4.0
Removing SupTitle.dll and SupCore.dll from plugin folder or uninstalling .NET 4.0 solved the problem.


May 10th, 2010, 7:01 pm
Profile
Site Admin

Joined: July 4th, 2008, 2:56 pm
Posts: 226
Post Re: Incompatibility with .Net Framework 4.0
You'll have to install .NET Framework 2.0. Installing v4.0 does not automatically install v2.0 as well.


May 11th, 2010, 12:24 am
Profile

Joined: May 10th, 2010, 6:37 pm
Posts: 6
Post Re: Incompatibility with .Net Framework 4.0
ZachSaw, thanks for the replay.

Windows 7 comes with 3.5SP1 and I think it includes all components of 2.0, 3.0 and 3.5.
But I tried to install 2.0 after installing 4.0 and the 2.0 installer gives me the error "You must use Turn Windows features on or off in Control Panel".
I can only turn on or off 3.5SP1, so there' no way I can install 2.0.

With 3.5SP1, I have no problem with SupTitle.dll and am able to use sup file from my BD with avisynth script.
I guess .NET 4.0 brakes components of 2.0.


May 11th, 2010, 1:49 am
Profile
Site Admin

Joined: July 4th, 2008, 2:56 pm
Posts: 226
Post Re: Incompatibility with .Net Framework 4.0
Have you restarted your machine after installing .NET 4.0?


May 11th, 2010, 3:45 pm
Profile

Joined: May 10th, 2010, 6:37 pm
Posts: 6
Post Re: Incompatibility with .Net Framework 4.0
Yep. Still get the same error, though.
I'd say, stay away from 4.0 ;)


May 12th, 2010, 1:01 am
Profile
Site Admin

Joined: July 4th, 2008, 2:56 pm
Posts: 226
Post Re: Incompatibility with .Net Framework 4.0
I've got .NET 4.0 installed and SupTitle's working just fine.


May 12th, 2010, 10:43 am
Profile

Joined: May 10th, 2010, 6:37 pm
Posts: 6
Post Re: Incompatibility with .Net Framework 4.0
Really?
Hmm, are you using Win 7?


May 12th, 2010, 5:30 pm
Profile
Site Admin

Joined: July 4th, 2008, 2:56 pm
Posts: 226
Post Re: Incompatibility with .Net Framework 4.0
XP. Haven't tried on Win7.


May 13th, 2010, 3:59 pm
Profile

Joined: May 10th, 2010, 6:37 pm
Posts: 6
Post Re: Incompatibility with .Net Framework 4.0
I just used my friend's PC(XP) to check if I get the same error.
The result is, everything's fine.
I think the problem is compatibility with Windows 7 and maybe, 64-bit? Not sure 'bout this 'cause I don't have Win 7 32-bit.


May 13th, 2010, 7:38 pm
Profile

Joined: April 26th, 2010, 10:52 am
Posts: 11
Post Re: Incompatibility with .Net Framework 4.0
I'm running Windows 7 Pro x64 and have no issues with SupTitle.


May 18th, 2010, 1:02 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 13 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB.